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Projektowanie

stron
internetowych

w pakiecie
Adobe
Photoshop

Rozpoczynajqc proces projektowania
strony internetowej, zawsze nalezy zasta-
nowic sie, co na niej bedzie umieszczane.

Po jej stworzeniu nie ma sensu doktadac
coraz to nowych kategorii, ktore przyjdq
nam do gtowy, poniewaz w pewnym
momencie zostanie catkowicie zatarta
idea strony.

anim przystapimy do prac zwigzanych z projek-

towaniem strony, warto zastanowic sie, 0 czym
bedzie ta strona i z jakich elementéw bedzie sie sktadac,
czego bedziemy potrzebowali do wykonania projektu i —
co najwazniejsze - jak bedzie ten projekt wygladat. Warto
sporzadzi¢ szkic strony na kartce papieru, opracowac jej
uktad, rozrysowac sobie szkielet struktury strony.

ELEMENTY STRONY INTERNETOWEJ

Na poczatek warto zastanowic sie, jak i gdzie beda
porozmieszczane elementy na naszej stronie, w kté-
rym miejscu bedzie menu, gdzie umiescimy tres¢ gtow-
na, jak duzy bedzie nagtéwek, a jak duza stopka. Rozwig-
zanie tych problemoéw przychodzi z czasem. Wraz z ilo-
$cig wykonanych stron nabiera sie coraz wiekszej wpra-
wy przy ich projektowaniu.

MENU

Jednym z najwazniejszych elementéw strony inter-
netowej jest menu. Musi ono by¢ przede wszystkim
dobrze widoczne. Przy rozbudowanych serwisach trze-
ba zastanowic sie nad taka organizacja menu, aby tatwo
byto dotrze¢ do pozadanych opcji. Warto skupi¢ sie na
tym, by menu byto proste, zeby nie zawierato zbyt wie-
lu opdji, w ktérych mozna bytoby sie zgubi¢. Odpowied-
nimi miejscami dla menu moga by¢: lewa strona, prawa
strona, lub géra. Rzadko, albo w ogéle menu umiejsco-
wione jest na dole strony, gdyz zaktéca to odbiér strony
przez czytelnika, ktéry przygotowany jest na to, ze znaj-
dzie menu ,tam gdzie zawsze". Wtasciwie kazdy element
wokét menu moze by¢ dowolnie dobrany, pod warun-
kiem, Ze nie bedzie go przyttaczat.

NAGLOWEK

Nagtéwek stat sie elementem reprezentacyjnym danej
strony czy organizacji, ktéra dzieki stronie chce sie poka-
zad. Przedstawia on profil dziatalnosci osoby, firmy, orga-
nizacji itp. Najczesciej jest to kompozycja fotografii oraz
efektéw graficznych, ktéra ma na celu przyciggnac¢ uwa-
ge ogladajacego. Ale czy to jest tak bardzo potrzebne?
Niekoniecznie. Ta cze$¢ moze zostac pusta, albo zawie-
ra¢ niewielka ilos¢ tresci, moze ona by¢ réwniez znacz-
nie wieksza niz sie wiekszosci z nas wydaje, aby wzboga-
ci¢ strone o ,,co$ innego”. Nic nie stoi na przeszkodzie, by
umiescic czes¢ lub cate menu w nagtéwku. Wzbogaci to
konstrukcje strony, oczywiscie jezeli jest ku temu okazja.

CZESC GLOWNA STRONY

Nastepnie nalezy opracowac¢ miejsce, w ktérym bedzie-
my zamieszczac gtéwna tres¢ strony. Moze sie wydawac,
Ze jest to tatwa czes¢ projektowania, bo przeciez wystar-

Artykut zostat opublikowany w magazynie Design Extra!l. Zapraszamy do lektury calego magazynu.

Szczego6ty na stronie internetowej www.psdmag.org. Wszelkie prawa zastrzezone.
Powielanie catosci lub czesci artykutu bez zgody Wydawnictwa - zabronione.

czytoby umiesci¢ element, ktéry informuje o danych
kategoriach, jaki$ tekst i moze jeden obrazek. Jednak
warto zastanowic sie, czy nie udoskonali¢ strony, two-
rzac jednolity interfejs, gdzie wszystkie elementy (na-
gtéwek, menu, czes¢ gtdwna, stopka) beda ze sobg pota-
czone. Jednym z najwazniejszych elementéw czesci,
gdzie znajduje sie tres¢, jest zaznaczenie miejsca, w kto-
rym sie jest. Jest to istotny element ze wzgledu na to, ze
w przypadku rozbudowanych stron ogladajagcemu cze-
sto zdarza sie zgubi¢. Bardzo czesto na stronach znajdu-
ja sie réznego rodzaju strzatki, punkty, elementy dodat-
kowe, ramki, petnigce funkcje nawigacyjna, i ktére warto
uwzgledni¢ w projekcie.

PRZYCISKI

W momencie, gdy projekt strony jest juz opracowany,
trzeba zastanowic sie, jak beda zachowywaty sie przyci-
ski w menu po najechaniu na nie myszka. Jezeli beda to
tylko zmiany formatowania tekstu, to nie ma problemu.
Natomiast gdy beda podmieniaty sie grafiki, to trzeba juz
zastanowic¢ sie nad opracowaniem tych grafik. Zazwy-
czaj sprowadza sie to do skopiowania menu i opracowa-
nia wersji strony po najechaniu myszka na poszczegol-
ne jej elementy. W tym wypadku warto opracowac sobie
i wypisa¢ nazwy wszystkich kategorii i podstron tak, by
pdzniej nie traci¢ czasu na dorabianie grafik.

projektowanie stron

PODSTAWOWE ZASADY
Jest kilka zasad, o ktorych warto pamietac podczas
projektowania stron w Photoshopie:

+  korzystamy z wiasnych pomystéw, staramy sie jak
najmniej kopiowac od innych;

» staramy sie wprowadzac coraz to nowe kompozycje,
dalekie od sprawdzonych standardéw (wciaz jednak
nalezy pamietac o szybkosci transmisji);

+ podczas projektowania staramy sie umieszczac kaz-
dy nowy element na nowej warstwie, dzieki temu
uzyskujemy wieksza kontrole nad projektem;

« staramy sie uzywac ujednoliconych krojéw czcio-
nek w projektach graficznych, ich niejednorodnos¢
moze przyciemni¢ sam projekt graficzny;

» staramy sie projektowa¢ jednolita kompozycje gra-
ficzna tak, by kazdy element tworzyt catos¢ z pozo-
statymi;

+ staramy sie tworzy¢ projekt w mysl ,diabet tkwi
w szczegdtach”, dbajac o szczegdtowos¢ wygladu
strony (czasem warto odczekac pare dni i wréci¢ do
projektu, mozna dzieki temu bardziej subiektywnie
popatrzec na to, co sie robi);

» gdy juz mamy gotowy layout, nalezy pokaza¢ go
innym, by mogli powiedzie¢ nam, co w nim trzeba
jeszcze dopracowaé. @

Nszystkie prawa zastrzeton

EN Projekt strony internetowej wykonany w Photoshopie

Design Extra! Nr 5 | www.dsx.pl

67



webdesign

68

Przygotowujemy tto

Tworzymy nowy obrazek
Plik->Nowy (ang. File—>New)
lub [Ctrl]+[N]. Ustawiamy roz-
miary obrazka: dtugos¢ 780,
szeroko$¢ 800. Wypetniamy
obrazek gradientem [G]
(jezeli mamy ustawione
Wiadro z farbg (ang. Paint
Bucket), wciskamy [Shift]+[G],
zeby przejs¢ do gradientéw)
z koloru RGB:[196,196,196] do
koloru RGB:[150,150,150].

Dodajemy kolor i gradient do selekcji

Zaznaczeniem [M] ustawiamy
obszar 255x140 px, gdzie
bedzie znajdowac sie menu,

i wypetniamy go kolorem
RGB:[255,198,0]. Do tego
uzyjemy Wiadra z farbg (ang.
Paint Bucket),; wciskamy
[Shift]+[G], zeby wroci¢ z gra-

Paint Bucket). Bez zdejmowa-
nia zaznaczenia wybieramy
ponownie gradient radialny,
zmieniamy wartos¢ pierwsze-
go koloru na RGB:[255,174,0],
a w opcjach gradientu

dientu do Wiadro z farbq (ang.

ustawiamy gradient radialny
z koloru do przezroczystosci
i wypetniamy zaznaczenie
na nowej warstwie tak, by
uzyskac efekt cieniowania.
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Dodajemy linie

Umieszczamy tekst menu,
wyréwnujac go do prawej
strony; rodzaj czcionki jest
dowolny. Umieszczamy
miedzy opcjami menu dwie
linie o wysokosci 1 px: gorng
koloru szarego (nie za ciem-
ny) i dolng koloru biatego,

a nastepnie zmniejszamy
stopien krycia do 40%.
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Dopracowujemy elementy menu

Powielamy teraz te war-

stwe tyle razy, ile jest opgji

w menu, odpowiednio
dopasowujac je do wygladu
menu. Na kolejnej warstwie
zaznaczamy obszar 35x140
px i wypetniamy go kolorem
RGB:[177,104,0]. Miedzy
dwoma obszarami koloru z6t-
tego i brazowego rysujemy
dwie kreski ztozone z biatego
i szarego koloru, by uzyska¢
wgtebienie. Po prawej stronie
dodajemy ozdobnik do kaz-
dej opcji w menu.
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Oddzielamy menu od reszty projektu

Oddzielamy nagtéwek i menu
od reszty projektu poprzez
wypetnienie obszaru 780x140
na najnizszej warstwie, ale
nie nizszej niz tto - gradient.
Powielamy dwukrotnie war-
stwe, gdzie wczesniej ryso-
walismy pionowe wgtebienie
Warstwa—->Powiel warstwe
(ang. Layer—>Duplikate),

a nastepnie przesuwamy ja
na lewy i prawy koniec menu.
Z prawej strony menu
zaznaczamy obszar 10x140 px
i wypetniamy go gradientem

liniowym z koloru szarego
RGB:[135,135,135] do przezro-
czystosci. Zmieniamy sposéb
przenikania na Mnozenie
(ang. Multiply) i zmniejsza-

my stopien krycia do 50%.
Duplikujemy te warstwe

i przenosimy ja na lewa strone
menu.
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Ostatecznie wydzielamy menu

Oddzielamy nagtéwek od
dolnej czesci, tworzac pas
szarego koloru o wymia-
rach 780x30 px. W gorne;j
czesci tworzymy wgtebie-
nie z jasnej i ciemnej linii.
Powielamy i przesuwamy na
dot. Ponizej i powyzej pasa
tworzymy cieni na takiej
samej zasadzie jak w punkcie
poprzednim.

Zaznaczamy pod menu
obszar o dtugosci 255 px

i przeciggamy zaznaczenie
do samego dotu. Wypetniamy

go gradientem z koloru RGB
[135,135,135] do koloru RGB
[109,109,109].

Dodajemy lewa kolumne

Z lewej i z prawej strony
ograniczamy go pionowymi
kreskami koloru troche ciem-
niejszego od uzytych w gra-
diencie, np.: RGB [77,77,77],

i ponownie umieszczamy
cien, uzywajac gradientu

i zmiany sposobu przenikania
tak jak w kroku 8.

Kategorie w lewej kolumnie

Chcac odseparowac poszcze-
golne kategorie w lewej
kolumnie, zaznaczamy
obszar, w ktérym bedziemy
tytutowali dang kategorie.
Wypetniamy go jasniejszym
kolorem szarym. Na gorze i na
dole wykonujemy wgtebienie
za pomocag linii ciemnej i pod
nig jasne;j.

Umieszczamy tekst tytu-
towy dla tej kategorii.

Mozna dodac cien pod
tekstem, wybierajac z menu
Warstwa—>Styl warstwy—

>Opcje mieszania (ang. Layer
Style—>Blending Options).
Ustawiamy Krycie (ang.
Opacity) na 40%, Odlegfos¢
(ang. Distance) oraz Wielkos¢
(ang. Size) na 1, wszystko

w zaktadce Cieri (ang. Drop
Shadow).
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Przygotujemy czesci pod splash-screen

Przygotujemy teraz prze-
strzen pod splash-screen
(obrazek wprowadzajacy

do stron). Po prawe;j stronie
odseparujemy kawatek
przestrzeni i wypetnimy jg
jednolitym kolorem np. RGB:
[114,116,115]. Ponizej ogra-
niczymy go jasnag kreska RGB:
[214,214,214].

Aby uzyska¢ wrazenie
wiekszej przestrzeni, pod
kreska rysujemy gradient

z koloru RGB:[192.192.192]
do przezroczystosci, mniej

wiecej na wysokos¢ 30 px,
oraz dodajemy cien powyzej
kreski na podobnej zasadzie
jak wezesdniej.

(] @[] Dodajemy ramke

W tym samym miejscu rysu-
jemy ramke o grubosci 3 px:
zaznaczamy obszar 415x150
px, wypetniamy go kolorem
RGB [192,192,192] i wybiera-
my z menu Zaznacz->
Zmien->Zawezanie (ang.
Select->Modify—>Contract).
Ustawiamy liczbe na 3,
przez co nasze zaznaczenie
zmniejszyto sie o 3 punkty na
kazdym z bokoéw.

m Umieszczamy splash-screen

Wybieramy Edycja—>Wytnij
(ang. Edit->Cut) lub [Ctr+[X],
dzieki czemu usuniemy
niepotrzebny obszar. Do
wewnetrznego obszaru
przenosimy obrazek o roz-
miarze 409x144. Obrazek
powinien kolorystycznie

i tresciowo nawigzywac oraz
komponowac sie z calym
projektem.

(({J WA Planujemy nagtéwek

Wracamy do grupy warstw
menu nagtéwek, gdzie
umieszczamy mape Swiata,
najlepiej zaraz nad wypetnie-
niem, na cafg szerokos¢ stro-
ny tak, by komponowaty sie
cienie utworzone wczesdniej.
Oprécz tego wkomponujemy
swoje logo lub inny element,
by wprowadzi¢ identyfikacje
sieciowg tworcy na stronie.

www.dsx.pl
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(] k] Tworzymy stopke

Do ogélnego projektu
brakuje nam jeszcze stopki.
Tworzymy zaznaczeie 780x30
px i wypetniamy je gradien-
tem linearnym z koloru RGB
[129,129,129] do koloru RGB
[113,113,113].

Nad nim ograniczamy ele-
ment pozioma kreska o nie-
wiele ciemniejszym odcieniu
szarego i powyzej linii robimy
cien za pomoca gradientu

W tym miejscu mozemy
napisac tekst na temat praw

i sposobu przenikania warstw.

autorskich dotyczacych
projektu.
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LG Formatujemy newsy

Kolejnym etapem tworze-
nia projektu strony jest
opracowanie jej zawartosci.
Miejscem na zamieszczanie
informacji o nowosciach na
stronie bedzie lewa kolumna,
ktéra bedzie pokazywac sie
na kazdej podstronie tak,
aby jak najszybciej dotrze¢
do odwiedzajacych strone
z nowymi informacjami.

W odseparowanym miejscu
w lewej kolumnie przy-
gotujemy odpowiednie
formatowanie dla kazdego

newsa. Dobrze jest uzywac

w projekcie czcionek, ktére
ostatecznie bedg uzyte juz na
stronie. Przyktadowa czcionka
i najczesciej uzywang przy
produkgji stron jest Verdana
lub Arial.
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LG &Y Wytaczamy warstwy

Po prawej stronie tuz pod
naszym splash screenem
bedziemy zamieszczac
gtéwna tresc strony.
Przygotowujemy tto pod
nagtéwek. Dla lepszego roze-
znania w wygladzie projektu
dobrze jest umiesci¢ wiecej
warstw z tekstami kategorii,
wylaczajac widocznosé tych,
ktore nie sg nam potrzebne
w danym momencie.
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(] @Y Dzielimy projekt

W Image Ready przygotowu-
jemy linie ciecia. Wtaczamy
linijki wokét obrazka Widok->
Miarki (ang. View->Rulers)

lub [Ctr1+[R]; klikajac na
linijki, przeciaggamy kursor

na pozadang cze$¢ obrazka.
Wygodniej bedzie nam, jesli
podzielimy sobie nasz projekt
na cztery czesci: gora - nagto-
wek i menu, lewa strona,
prawa strona oraz stopka.
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(] WA Tniemy projekt w Image Ready

Duplikujemy obrazek cztery
razy za pomocg Obrazek—>
Powiel (ang.Image—>
Duplicate) i z kazdego wycia-
gamy odpowiedni fragment
projektu. Zaznaczamy okre-
$lone fragmenty narzedziem
Zaznaczenie prostokatne
(ang. Marquee) [M] i wybiera-
my z menu Obrazek->Kadruj
(ang. Image—>Crop) (linie
pomocnicze zostaty popro-
wadzone w pliku site.psd).
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(] K] Pociety na kawatki fragment projektu

W pocietych fragmentach

w naszych plikach PSD zosta-
ty juz poprowadzone linie
pomocnicze. Trzeba przewi-
dzie¢, ktore fragmenty grafiki
beda powielane, by uzyskac
ciggtos¢ grafiki i odpowied-
nio przygotowac sobie linie
pomocnicze tak, by wycinaty
potrzebne fragmenty grafik
do powielenia. Gdy sa
utozone linie pomocnicze
(mozna to zrobi¢ zarébwno

w Photoshopie jak

i w Image Ready) prze-

chodzimy do Image Ready
([Ctrl1+[Shift]+[M]). Od razu

W programie otworzy sie
obrazek, ktory byt aktywny

w Photoshopie. Aby pocia¢
fragment na kawatki wedtug
przygotowanych wczesniej
linii pomocniczych, wybiera-
my z menu Odciecia->Utwdrz
odciecia z linii pomocniczych
(ang. Slices—>Create Slice from
guides). Na naszym obrazku
pojawia sie numery kolejnych
prawie juz pocietych kawat-
kow.
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m Format zapisu odciec¢ (ang. slice)

Pozostaje zdefiniowanie,
ktéry kawatek bedzie zapisa-
ny w formacie JPEG, a ktory
w GIF. Wybieramy z belki
narzedziowej Zaznaczanie
odciecia (ang. Slice Select Tool)
[K] i wybieramy interesujace
nas kawatki.

W palecie Optymalizuj

(ang. Optimize) wybieramy
format pliku oraz parametry
dla danego formatu. Jezeli
jest mata liczba koloréw,
powierzchnie sa w miare
jednolite kolorystycznie albo

kawatki sg niewielkie, to nie
warto uzywac formatu JPEG,
ze wzgledu na to, iz traci sie
jakos¢ obrazu i zwieksza sie
objetos¢ plikow.

[({o] @it] Opcje zapisu plikéw

Gdy wszystkie kawatki sg juz
poukfadane i poustawiane,
wybieramy z menu Plik->
Zapisz Zoptymalizowany jako
(ang. File—->Save Optimized
As) lub [Ctrl]+[Alt]+[Shift]+[S].
W nowym oknie wybieramy
miejsce, gdzie majg by¢ zapi-
sane pliki. Wybieramy jeszcze
Ustawienia->Inne (ang.
Settings—>Other) i w nowym
oknie koriczymy ustawianie
zapisu.

W opcji Zapisywanie plikéw
(ang. Saving Files) mozna

zdefiniowa¢ doktadnie nazwy
plikéw, ich numeracje oraz
lokalizacje. Zatwierdzamy OK
i zapisujemy pliki. Po wejsciu
do wskazanego wczesniej
katalogu, zobaczymy pliki
HTML oraz w katalogu Images
pociety fragment na pliki,
ktore byty wczesniej zdefinio-
wane w Image Ready.
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